Tonido SSL not working

Support for Tonido on the Desktop including Windows/Mac/Linux
mzenhorst
Rookie Tonidoid
Rookie Tonidoid
Posts: 4
Joined: Mon Nov 07, 2016 3:26 am

Tonido SSL not working

Postby mzenhorst » Mon Nov 07, 2016 7:19 am

Hello,

I have tried to setup the Tonido SSL as specified on http://www.tonido.com/support/display/docs/Tonido+Biz.
However It is not working. I checked other topics but none of them provide useful information.

1. I have created a SSL certificate from StartSSL.
To create it I created a CSR first:

Code: Select all

openssl req -newkey rsa:2048 -keyout <domain>.nl.key -out <domain>.nl.csr


2. I then created a private key on my server:

Code: Select all

openssl rsa -in <domain>.nl.key -out unencrypted.key



3. I copied the unencrypted key and <domain>.nl.pem file I got from StartSSL content into servercert.pem.
The pem file was copied to the location where the BIZ package is located (which is correct since I do see other icons appearing on the web interface after changing them there).
Tested using

Code: Select all

openssl s_server -cert servercert.pem -www

Result:
Using default temp DH parameters
ACCEPT

4. Changed the config_pro.xls to ensure it is using the SSL.

Code: Select all

<?xml version="1.0" encoding="UTF-8" ?>
<variantrow>
        <rowentry>
                <name>EnableHTTPS</name>
                <type>bool</type>
                <value>1</value>
        </rowentry>
        <rowentry>
                <name>ServerCertKey</name>
                <type>string</type>
                <value>tonido</value>
        </rowentry>
</variantrow>


5. I turned off relay and turned on SSL on the Settings as indicated on the page.
and restarted.

As this did not result in a working situation I enabled tracing (see attachment).
This doe snot contain anything interesting other then that it confirms that it only starts the HTTP interface.
Like in Topic http://www.tonido.com/forum/viewtopic.php?t=9900.

- I generated the key and certificate for <domain>.nl without any port number (I do not know whether this is required or not).
- The server is running on a non standard port (non 80/10001/443).

If anything is missing I'll be willing to share, however I would rather not post identifiable information on a public forum.
When is the HTTPS service started (which parameter setting is required)?

Kind regards,
Mark Zenhorst
Attachments
TonidoLogging.log
(12.65 KiB) Downloaded 292 times

nagapriya
Tonido Team
Tonido Team
Posts: 97
Joined: Tue Oct 18, 2016 9:20 am

Re: Tonido SSL not working

Postby nagapriya » Thu Nov 10, 2016 4:13 am

we are working to simulate this issue.

mzenhorst
Rookie Tonidoid
Rookie Tonidoid
Posts: 4
Joined: Mon Nov 07, 2016 3:26 am

Re: Tonido SSL not working

Postby mzenhorst » Thu Nov 10, 2016 5:12 am

Hello,

thank you for the update.
Please keep me updated on the progress.

Regards,
Mark Zenhorst

iG0R
Rookie Tonidoid
Rookie Tonidoid
Posts: 4
Joined: Sun Nov 06, 2016 4:29 am

Re: Tonido SSL not working

Postby iG0R » Tue Nov 15, 2016 12:43 pm

Hello.
It's a very old issue. Here is the discussion viewtopic.php?f=14&t=9900&hilit=ssl
I also have the same problem and already tired of waiting for it resolving.

mzenhorst
Rookie Tonidoid
Rookie Tonidoid
Posts: 4
Joined: Mon Nov 07, 2016 3:26 am

Re: Tonido SSL not working

Postby mzenhorst » Mon Nov 21, 2016 6:25 am

Hello,

I know since I searched the topics before creating a new one.
I found my situation to be slightly different given the fact that I'm using a different certificate authority and perhaps they would be able to resolve this with additional information. Also I asked the question how tonido decides whether to start the ssl server, which would also help understanding the issue at hand here.

Regards,
Mark

iG0R
Rookie Tonidoid
Rookie Tonidoid
Posts: 4
Joined: Sun Nov 06, 2016 4:29 am

Re: Tonido SSL not working

Postby iG0R » Mon Nov 21, 2016 9:03 am

Hello,

I think, as a temporary solution, we can use a reverse proxy. E.g. IIS has a very comfortable implementation to obtain a certificate from letsencrypt with the help of letsencrypt-win-simple https://github.com/Lone-Coder/letsencrypt-win-simple

Best regards,
Igor.

mzenhorst
Rookie Tonidoid
Rookie Tonidoid
Posts: 4
Joined: Mon Nov 07, 2016 3:26 am

Re: Tonido SSL not working

Postby mzenhorst » Wed Apr 05, 2017 4:56 am

nagapriya wrote:we are working to simulate this issue.

Hello,

Any news yet on the simulation/resolution of this issue?

Regards,
Mark

User avatar
madhan
Admin Tonidoid
Admin Tonidoid
Posts: 8617
Joined: Tue Dec 30, 2008 12:13 am
Location: Austin, TX, USA
Contact:

Re: Tonido SSL not working

Postby madhan » Sun Apr 09, 2017 12:26 pm

Have you tried this with the latest Tonido release currently available?


Return to “Tonido Software”

Who is online

Users browsing this forum: No registered users and 6 guests