WIN32 Debug vs Release Build in tonido issue?

Questions related to developing on the Tonido Platform
yvl
Regular Tonidoid
Regular Tonidoid
Posts: 19
Joined: Tue Aug 11, 2009 6:21 am

WIN32 Debug vs Release Build in tonido issue?

Postby yvl » Thu Sep 24, 2009 4:03 am

Hi, I've just tried out the SDK , it is impressive
-> Setup: Windows & Vs.net 2008

I've the following Issue:
When I build in DEBUG or RELEASE mode I can run the sample plugins in tonidoconsole without any issue.

Howewer I can not activate the sample plugins in the standard tonido (Windows,version 0.2.0.9648) if they are build in debug mode (see log below)
If I install the release build of the plugins it does works in the standard tonido



10:39:15:281 [4] [TCPServerConnection (default[#2])]:T: HTTP Request [127.0.0.1] [GET] [/ui/core/common/img/dialog_question.gif]
10:39:16:669 [3] [TCPServerConnection (default[#1])]:T: HTTP Request [127.0.0.1] [GET] [/core/resumeplugin?plugin=plugins%5Cdummy%5Cdummy.dll&time=1253781556667]
10:39:16:671 [5] [UserManager]:I: resume plugin plugins\dummy\dummy.dll
10:39:17:353 [5] [UserManager]:E: Library Load Exception: plugins\dummy\dummy.dll:Cannot load library
10:39:17:353 [5] [UserManager]:T: Failed to load plugin..plugins\dummy\dummy.dll

User avatar
madhan
Admin Tonidoid
Admin Tonidoid
Posts: 8617
Joined: Tue Dec 30, 2008 12:13 am
Location: Austin, TX, USA
Contact:

Re: WIN32 Debug vs Release Build in tonido issue?

Postby madhan » Thu Sep 24, 2009 9:12 am

Good to hear you got going.

Yes, by design. Remember the debug build runtime code is not allowed to be mixed with release build runtime (atleast in Windows). So use debug mode for development, once you are happy, switch over to release.


Return to “Tonido Platform Development”

Who is online

Users browsing this forum: No registered users and 10 guests