Failed Download - Bad HTTP

New Sync App released in 13.0 (October 2016)
silklink
Regular Tonidoid
Regular Tonidoid
Posts: 10
Joined: Tue Oct 10, 2017 6:47 am
Location: Cornwall, UK

Failed Download - Bad HTTP

Postby silklink » Mon Oct 23, 2017 7:00 am

Hi

I'm highlighting this issue here in the Synch 2 area just in case I've posted it in the wrong area

viewtopic.php?f=14&t=11636

Sorry if this is the wrong thing to do, but I don't have much hair to pull out now :D

enricof
Rookie Tonidoid
Rookie Tonidoid
Posts: 4
Joined: Sat Dec 16, 2017 5:10 am

Re: Failed Download - Bad HTTP

Postby enricof » Tue Dec 26, 2017 6:49 am

Same here.
For each file I try to syncronize, I receive the Bad Http Status error message.
If I browse file, instead, I'm able to see them.

silklink
Regular Tonidoid
Regular Tonidoid
Posts: 10
Joined: Tue Oct 10, 2017 6:47 am
Location: Cornwall, UK

Re: Failed Download - Bad HTTP

Postby silklink » Wed Dec 27, 2017 5:05 am

I managed to resolve most of it by literally copying everything on the server and my wife's laptop onto an expansion drive and then blowing away the server and client side of Tonido and copying back the expansion drive's contents, and then running synch

However, after a few weeks of success, I still get this issue for a handful of files. I have no clue why it does this because these files have not been altered

Sreeja
Tonido Team
Tonido Team
Posts: 368
Joined: Mon Dec 16, 2013 4:25 am

Re: Failed Download - Bad HTTP

Postby Sreeja » Mon Jan 22, 2018 11:49 pm

This issue is due to the flaky internet connection.
For further analysis, Can you please send us the logs ?

gary0318
Rookie Tonidoid
Rookie Tonidoid
Posts: 2
Joined: Thu Feb 01, 2018 9:42 am

Re: Failed Download - Bad HTTP

Postby gary0318 » Sat Feb 03, 2018 8:19 pm

Postby Sreeja » Mon Jan 22, 2018 11:49 pm

This issue is due to the flaky internet connection.
For further analysis, Can you please send us the logs ?


But, my internet isn't flaky and this is happening to me. My phone clients are on the same internet services and routers as my sync 2 clients. But, the sync 2 clients get this Failed Download message. When I open up the client's browser, I can look at everything that is being shared in the browser. But, I cannot download anything without getting this error. And, also, there is no realtime syncing of data to the client. This is true on Windows clients and Linux clients. I could use some help. I would love to be able to depend on this. It beats a cloud on someone else's machines.

It also shows messages that say the folders don't exist. But they do. And, the phone clients can access them just fine.

TonidoSync2.PNG
TonidoSync2.PNG (75.34 KiB) Viewed 6525 times


I have also attached a copy of the windows client log:

syncclient.log
(14 KiB) Downloaded 392 times


Thanks,

enricof
Rookie Tonidoid
Rookie Tonidoid
Posts: 4
Joined: Sat Dec 16, 2017 5:10 am

Re: Failed Download - Bad HTTP

Postby enricof » Fri Feb 16, 2018 6:12 am

Sreeja wrote:This issue is due to the flaky internet connection.
For further analysis, Can you please send us the logs ?


Tonido now doesn't syncronize files at all.
Attached one is a file with both client and server side logfile with all time client attempts since December 2017 trying to get Tonido to work:
(I've censored some information for privacy)

Thank you
Best regards
Attachments
TonidoLOGs.txt
(2.29 MiB) Downloaded 382 times

Sreeja
Tonido Team
Tonido Team
Posts: 368
Joined: Mon Dec 16, 2013 4:25 am

Re: Failed Download - Bad HTTP

Postby Sreeja » Tue Mar 20, 2018 6:43 am

Hello gary0318,

Thanks for the logs !
We caught some exceptions from the logs. We'll forward it to the development team and get back to you on this.

enricof
Rookie Tonidoid
Rookie Tonidoid
Posts: 4
Joined: Sat Dec 16, 2017 5:10 am

Re: Failed Download - Bad HTTP

Postby enricof » Mon Jun 18, 2018 5:07 am

Is this project still alive?
Because waiting for 8 months to solve a problem that make Tonido unusable I think is too much...

silklink
Regular Tonidoid
Regular Tonidoid
Posts: 10
Joined: Tue Oct 10, 2017 6:47 am
Location: Cornwall, UK

Re: Failed Download - Bad HTTP

Postby silklink » Sun May 05, 2019 12:49 pm

Nearly a year on and I'm still getting this issue but only with a guest account. It seems no matter what I do - event refreshing the server-side files - they will not download to the guest client (where all files are deleted)

Did the developers find anything?

Oh, and I'm on the same network and it works for me - not a flaky network

silklink
Regular Tonidoid
Regular Tonidoid
Posts: 10
Joined: Tue Oct 10, 2017 6:47 am
Location: Cornwall, UK

Re: Failed Download - Bad HTTP

Postby silklink » Sat May 11, 2019 7:55 am

Been doing some more investigation to try and resolve this issue

I cleared the data and accounts completely from both the server and the guest client. I then tried putting the data on just the server - no joy - and then the client - still no joy

I now have it set to backup mode for my guest account - still not working

I get this popping up in the corner from Tonido - Backup has been disabled by Admin

It keeps trying and every few minutes I get the above message popping up

The client guest account is able to log on and the Trace error file looks like this every time the client tries to backup

13:33:04:932 [24] [TCPServerConnection (default[#13])]:T: HTTP Request [127.0.0.1] [GET] [/]
13:33:05:050 [14] [TCPServerConnection (default[#3])]:T: HTTP Request [192.168.1.75] [POST] [/core/loginguest]
13:33:05:051 [5] [UserManager]:E: Cannot log into different profile when another profile is logged in
13:33:05:169 [6] [Dispatcher]:E: Token not found in List: c875bc23-7577-4bc2-8c21-2ca8203ad8cb
13:33:05:205 [24] [TCPServerConnection (default[#13])]:T: HTTP Request [192.168.1.75] [GET] [/core/getsystemstatus?nousage=0]

I thought maybe it was because I was logged on to the Admin account and so I logged out, but I still get the same issue

Before all of this investigation and changes made, I noticed that the log file had these two lines in (different times)
13:33:05:051 [5] [UserManager]:E: Cannot log into different profile when another profile is logged in
13:33:05:169 [6] [Dispatcher]:E: Token not found in List: c875bc23-7577-4bc2-8c21-2ca8203ad8cb

So, even though I have deleted and re-created the guest account, is there something still cached somewhere?

I'll need to go-get a different solution if I can't get this working - it's important for my wife's business - so any help would be appreciated

Remember - my admin account and client I am using with the same server is working as expected. It's just the guest account that won't work for me


Return to “Tonido Sync 2”

Who is online

Users browsing this forum: No registered users and 1 guest