Page 1 of 1

Mac 10.6 problem with Sync

Posted: Fri Aug 19, 2016 2:12 pm
by Dash
I have a Intel CoreDuo MacBook. On the web I read the Mac server needs 10.8 os but the Sync is good for 10.5 and up. When I try to install Sync it says it doesn't work with my model. So what is wrong? Is there an older Sync that will work? Thanks for any help.......Dash