Page 1 of 1

Tonidoplug2, SSD becomes unmounted/undetected

Posted: Thu Apr 17, 2014 3:43 am
by moralis
Hi Tonidofriends ;)

The following problem makes my TP2 kind of useless to me. SO I hope we can fix this problem together.

I put a Crucial M500 240GB SATA 2.5-Inch SSD in my TP2 and everything works out of the box... in the beginning. After some time (I guess after 3 to 4 hours when the plug is idle) the SSD is not mounted anymore. At least this is what I assume, because of the following errors:

- I cannot upload files/create folders on the SSD via my Laptop's Samba share
- the same is true if I ssh into the plug
- I also cannot upload files/create folders via the TP's web interface
- the SSD does not show up under the "Disks" tab in the TonidoPlug-Admin interface

As mentioned, this problem occurs after the plug (or the SSD respectively) is idle. When I restart the hardware the SSD is recognized again, mounted to a different mount point (to disk2part1 instead of disk1part1), and I do not encounter any of the above described errors. However after some idle time the SSD disappears again.

I also tried to disable the SSD's power save function using hdparm (this was the only solution I could find here), but this did not seem to work.

Thank you for your help!

PS: I attached the trace log file.

Re: Tonidoplug2, SSD becomes unmounted/undetected

Posted: Sat Apr 19, 2014 9:21 am
by Tuxedo
Hi,
The problem you are describing seems to be a power save mode problem.
You can check for your SSD model. There might be some tools available (may be in windows), to disable this power save mode.
Since this is a hdd dependent feature, we are not able to set that as a default in plug OS.

Re: Tonidoplug2, SSD becomes unmounted/undetected

Posted: Sun Apr 20, 2014 11:56 am
by marioscube
Boot the Tonidoplug from the SSD. Link: http://www.tonido.com/communitywiki/doku.php?id=advanceduses:usbboot

That way the SSD will (hopefully) stay "active".

Re: Tonidoplug2, SSD becomes unmounted/undetected

Posted: Mon May 05, 2014 1:33 pm
by moralis
Thank you for your answers!

I tried to disable the power save mode with hdparm but it did not help (even though the power save was disabled according to hdparm -I ). I will check with crucial if there is another way to do this.

I also booted from the SSD directly and this was not a solution either. After 4 hours the plug was not accessible through the web interface neither via a samba share. sshing into the plug was still possible but I could not do stuff, like copying files or creating folders. The plug would even stop working after I established an hourly cron job touching a file and writing a line to it.

Right now I use an old HD from a laptop and it works as it should. But I would really like to have a SSD in my TP2 since it's a bit calmer and much cooler. Any suggestions which SSDs will work for me? Does anybody has good experience with certain SSDs?

Re: Tonidoplug2, SSD becomes unmounted/undetected

Posted: Tue May 06, 2014 11:40 am
by moralis
Ok, I have contacted Crucial and they think the problems I describe have something to do with the power cycle:
"The issues you describe are consistent with an operating system or BIOS that may be cutting power to the SSD. The power saving mode on the SSD should not be causing the issues you describe. I would check and see if you have any power saving or hibernation modes enabled in the system BIOS or in the operating system. "

However in order to troubleshoot they need the following information about the TonidoPlug2:

* Motherboard/System Make/Model:
* Motherboard/System BIOS Revision:
* SATA Speed: SATA 1 (1.5 Gb/s), SATA 2 (3.0 Gb/s), SATA 3 (6.0Gb/s)
* BIOS SATA mode (IDE/ AHCI/ RAID):
* Operating System:

Is there an easy way to find out those things?