Page 1 of 1

TonidoPlug Unable to Communicate With Server

Posted: Wed Jul 11, 2012 12:36 am
by atersol
tonidoplug.com/ip successfully finds both of my tonidoplugs (version 1 & tonidoplug2)

Connect to tonido for the tonidoplug2 works fine

Connect to tonido for version 1 goes to 192.168.1.103:10001/ui/core/index.html
a. nothing comes up some of the time
b. Could not connect to remote server [web browser message]
c. get message "Unable to Communicate With Server" [looks like Tonido message]
under details:
Error: Failed Loading Translations
Either the service is not running, or
the service is not responding!

Then goes to a page showing -

Tonido Accounts
New Account
Select an existing account to login or create a new account
[acctID]
[acctID]

Password Login options

If I enter my password, and click Login, get popup saying Please Wait, Logging In
Then popup goes away, and nothing.

I have used putty to SSH.

Tried "How to fix TonidoPlug flash disk full issue

# rm -rf *
rm: cannot remove '*'; Input/;output error
root@TonidoPlug:/media/disk1part1# ls
ls: cannot open directory .: Input/output error

did software reset, which seemed to go fine.
cd /root/app/tonido
wget http://patch.codelathe.com/tonido/live/ ... ido.tar.gz
tar -zxvf tonido.tar.gz

I can SSH.
ls results in
"app discoverd tonido_usbmount.log"

one LED red
one LED blue mostly, sometimes yellow

I've tried unplugging, replugging. LED

I've downloaded log files, attached.

Every once in a while, it acts normally. It just did.
It allowed me to go in and cleanup - successful.
Both before and after cleanup "Internal Flash -- -- Used: 359M of 462M
Then I was restarting Applications. A number were successfully restarted, then
I got "Unable to Communicate With Server"
Details: "Error: Failed Application Action!
Either the service is not running, or
the service is not responding!"

close the window, retry, and I get
"Failed Application Action!
Bad Role"

Had to re-login, then went to admin and login as root.
restart software

Now when I go to applications, it says
"No applications have been installed for this profile.
Click here to install new applications"
I click, it takes me to Install tab, which says
"No Applications are available for installation"

restart hardware
go to applications. They are back, but all suspended.
Turn some of them on one by one

Most are ok, but Photos I get "Unable to Communicate with Server"
More Details
Error: Directory list error
Either the service is not running, or
the service is not responding!

Bottom line: the TonidoPlug is acting flaky. It works intermittently, but is not reliable.
I've tried other network cables, so don't know what else I can do.

I've attached log files.

Thanks for any help you can offer.

Re: TonidoPlug Unable to Communicate With Server

Posted: Wed Jul 11, 2012 10:45 am
by madhan
We deprecated Photos/OpenID apps.
So until you delete them it is going to act flaky.

See
viewtopic.php?f=32&t=5097&p=24394&hilit=%2Fapp%2Ftonido%2Fplugins#p24394

Re: TonidoPlug Unable to Communicate With Server

Posted: Wed Jul 11, 2012 11:50 am
by atersol
Instructions in link a little misleading.

I tried from the web interface, went to plugadmin first to log on as root, then navigated to root/app/tonido/plugins, but when I try to delete it says "Deletion is not permitted in this directory". Perhaps with SSH it would work that way.

I was able to go to Applications, and uninstall photos and openid from there. Restarted software, and so far so good.

Thanks.

Re: TonidoPlug Unable to Communicate With Server

Posted: Sat Mar 23, 2013 11:04 am
by neato
Deleting the folders

~/app/tonido/photos
~/app/tonido/openid

worked for me. I was not able to log in prior to this after upgrading. I had to do this via ssh.

The new interface looks great so far. Good work!