Page 1 of 1

relay service timeout

Posted: Wed Jan 04, 2012 5:50 pm
by spartacus
After replacing my wrt54G internal router with a newer/faster WNDR4500, I am having intermittent problems connecting to my tonido via the relay service. (the WNDR4500 sits behind my ISP-provided vDSL router to create a subnet for the plug).

Local connections work fine, but when accessing via the relay, I often get "internal server error - try again later" (or httpStatus 500) - the status (in misc->settings->network) shows as timedout or disconnected.

Regards,

Re: relay service timeout

Posted: Thu Jan 05, 2012 12:33 am
by madhan
that generally means that the connection to the relay is dropping out every so often. You can change your log level to trace and post your tonido.log and we can check for clues.

Re: relay service timeout

Posted: Thu Jan 05, 2012 7:45 pm
by spartacus
I tried several changes, so the log may not help...

In summary:

1. from tonidoplug.com/ip - works fine,
2. from mobile (via <my-account>.tonidoid.com) - works fine through either router,
3. from pc (on internal subnet 2) via tonido home link - 404

main (ISP) router has port 80 routed to subnet 1 server (my www site), but that has not changed. UPNP forwarding enabled on internal router/tonido, shows up for the set AdvertiseDuration (30 min) though (if I understand correctly) this should not be involved.

subnet 1 server is also running MythTV and http://<my public ip> accesses its page - but this too is unchanged from the wrt54g scenario (needs to be disabled).

Not sure what to try next. Clearly, not a Tonido issue, but any help appreciated.

Is there a description of the relay mechanism?

Regards,

Re: relay service timeout

Posted: Fri Jan 06, 2012 10:36 am
by madhan
When you connect to the Tonido URL, try this full URL.
http://xyz.tonidoID.com/ui/core/index.html and see if it works.

Re: relay service timeout

Posted: Fri Jan 06, 2012 11:30 am
by spartacus
works - treated as remote login with secret question.

Regards,

Re: relay service timeout

Posted: Fri Jan 06, 2012 11:49 am
by madhan
ok, that means that the WAN to LAN switching is not working because of the subnet.
When it switches, what is the IP you see you see that is not accessible?

Re: relay service timeout

Posted: Fri Jan 06, 2012 1:11 pm
by spartacus
cleared Firefox history, can now access via tonidoid.com, but only if on the same subnet (2) as plug. Trying to access from a client on subnet 1 fails (which it should if I tried to get to subnet 2 directly)

wifi mobile access via tonidoid.com still works via either router.

Something is still messed up though: netgear log shows multiple ICMP echo requests (being blocked) even though ISP router is set to max protection.

Regards,