Changing the kjournald / ext3 commit interval

Support for your TonidoPlug
User avatar
scott_mebust
Super Tonidoid
Super Tonidoid
Posts: 28
Joined: Sat Aug 29, 2009 9:43 am

Changing the kjournald / ext3 commit interval

Postby scott_mebust » Tue Sep 01, 2009 1:12 pm

I wanted to go with ext2 formatted flash drive but, because of the (bug) inability to unmount an ext2 formatted device, went with ext3. However, the journaling commit interval is set to 5 seconds and I'd like to change that. I can't remember how, though - it's been a while since I'd played with things like laptop mode and changing spindown, commit intervals, etc.

Anyone know off-hand how to change the commit interval?

Is it something in /etc/sysctl.conf ? It's not going to be a mount option in /etc/fstab because the USB devices are mounted automatically by udev, right? Is it /etc/udev.conf or something in /etc/udev/rules.d ?

Aug 31 22:48:37 ginger kernel: usb 1-1: new high speed USB device using orion-ehci and address 2
Aug 31 22:48:37 ginger kernel: usb 1-1: configuration #1 chosen from 1 choice
Aug 31 22:48:37 ginger kernel: scsi0 : SCSI emulation for USB Mass Storage devices
Aug 31 22:48:37 ginger kernel: scsi 0:0:0:0: Direct-Access Patriot Memory PMAP PQ: 0 ANSI: 0 CCS
Aug 31 22:48:37 ginger kernel: sd 0:0:0:0: Attached scsi generic sg0 type 0
Aug 31 22:48:37 ginger kernel: sd 0:0:0:0: [sda] 125304832 512-byte hardware sectors: (64.1 GB/59.7 GiB)
Aug 31 22:48:37 ginger kernel: sd 0:0:0:0: [sda] Write Protect is off
Aug 31 22:48:37 ginger kernel: sda: sda1
Aug 31 22:48:37 ginger kernel: sd 0:0:0:0: [sda] Attached SCSI removable disk
Aug 31 22:48:37 ginger kernel: kjournald starting. Commit interval 5 seconds
Aug 31 22:48:37 ginger kernel: EXT3 FS on sda1, internal journal
Aug 31 22:48:37 ginger kernel: EXT3-fs: recovery complete.
Aug 31 22:48:37 ginger kernel: EXT3-fs: mounted filesystem with writeback data mode.


Tuxedo
Tonido Team
Tonido Team
Posts: 1458
Joined: Wed Jan 28, 2009 11:30 pm

Re: Changing the kjournald / ext3 commit interval

Postby Tuxedo » Wed Sep 02, 2009 8:37 am

Did you try mounting the external USB like this?

Code: Select all

 
# umount /dev/sda1   //make sure the device is not mounted already
# mount -o commit=30 /dev/sda1 /media/usb0

User avatar
scott_mebust
Super Tonidoid
Super Tonidoid
Posts: 28
Joined: Sat Aug 29, 2009 9:43 am

Re: Changing the kjournald / ext3 commit interval

Postby scott_mebust » Wed Sep 02, 2009 8:24 pm

I considered doing a remount with the commit option but I'd have to do that every time I rebooted, removed the drive, etc. Actually, I just ended up converting it back to an ext2 partition by doing this:

tune2fs -O ^has_journal /dev/sdc1
fsck.ext2 /dev/sdc1


with the USB drive on another system (as /dev/sdc1).

I do think I had some laptop-mode stuff (including changing the commit period, etc.) somewhere. :idea: Maybe I should check my laptop.


Return to “TonidoPlug Support”

Who is online

Users browsing this forum: No registered users and 10 guests