Booting TonidoPlug using USB Drive

Support for your TonidoPlug
rgtaa
Regular Tonidoid
Regular Tonidoid
Posts: 10
Joined: Mon Jun 07, 2010 5:31 pm

Re: Booting TonidoPlug using USB Drive

Postby rgtaa » Thu Aug 26, 2010 9:27 am


synxer
Rookie Tonidoid
Rookie Tonidoid
Posts: 5
Joined: Mon Sep 13, 2010 8:41 am

Re: Booting TonidoPlug using USB Drive

Postby synxer » Mon Sep 13, 2010 8:56 am

First I would like to stay that TonidoPlug is great and that I really enjoy the technology and thought behind it.

I am having a problem with the USB drive stuff, though.

- External USB Drive (500 GB, 70 GB partition for booting)
- APC USB Powered Hub
- Followed directions stated here: http://www.tonido.com/help/Index.htm?context=240
- Have good knowledge of Linux
- Can mount and utilize the drive, properly mounts at /media/disk1part1

I just can't get it to boot off of the drive. df -h shows the NAND as the rootfs and shows my mounted drive as well. The boot flag is enabled in fdisk as well.

I should also note that for a split second, I actually booted onto the other drive and then when I rebooted again it didn't come back.

Here are a few things from dmesg that look abnormal:

Not sure what this is:
EXT3-fs (sda1): mounted filesystem with writeback data mode
UBIFS: parse errors=continue
UBIFS error (pid 1465): ubifs_parse_options: unrecognized mount option "errors=continue" or missing value
UBIFS error (pid 1465): ubifs_remount_fs: invalid or unknown remount parameter

I can see that my USB hub is being detected:
hub 1-1.4:1.0: USB hub found
hub 1-1.4:1.0: 4 ports detected
usb 1-1.4.1: new high speed USB device using orion-ehci and address 5
scsi0 : usb-storage 1-1.4.1:1.0

And harddrive...
scsi 0:0:0:0: Direct-Access WDC WD50 00AAKS-00WWPA0 3B01 PQ: 0 ANSI: 2 CCS
sd 0:0:0:0: [sda] 976773168 512-byte logical blocks: (500 GB/465 GiB)

And then a bunch of, what appears to be, bad stuff:
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 0
Buffer I/O error on device mtdblock0, logical block 0
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 8
Buffer I/O error on device mtdblock0, logical block 1
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 16
Buffer I/O error on device mtdblock0, logical block 2
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 24
Buffer I/O error on device mtdblock0, logical block 3
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 0
Buffer I/O error on device mtdblock0, logical block 0

Any help that can be provided would be great!
Thanks!
Nick

Tuxedo
Tonido Team
Tonido Team
Posts: 1458
Joined: Wed Jan 28, 2009 11:30 pm

Re: Booting TonidoPlug using USB Drive

Postby Tuxedo » Mon Sep 13, 2010 11:19 am

Hi, It could be that your USB disk is not compatible to boot with the plug. For the plug the USB device should be ready in 10 secs for booting to happen. If the drive is slow (not the data transfer speed, the initial warm-up speed), then plug's bios would skip the USB and boot from the internal flash. You can try with another disk or an USB stick. Here is a link, where users post their USB disk compatibility experiences.

synxer
Rookie Tonidoid
Rookie Tonidoid
Posts: 5
Joined: Mon Sep 13, 2010 8:41 am

Re: Booting TonidoPlug using USB Drive

Postby synxer » Thu Sep 16, 2010 9:51 am

I'm a little frustrated at this point.

I'm not going to be "that guy".

Because other than this booting issue, I can see a fine-tuned, well oiled machine that is TonidoPlug. But, when I ordered the LAMP image I didn't get a cautionary message about hard drive support. I could understand it if this was mostly exclusionary, but after about 5 different hard drives (connected directly, or through 2 different powered USB hubs) I can see that this is inclusionary. As in, only a handful of drives will work.

From what I can see most drives don't work and most people on this forum who have attempted to use an external drive with the LAMP image have either failed or have given up (correct me if I am wrong here).

Is there something I can do to lengthen this boot time? I have read something *U-Boot* and perhaps using a serial adapter of some kind to modify.

Is there an updated explanation as to how this is done?

Kindly,
Nick

synxer
Rookie Tonidoid
Rookie Tonidoid
Posts: 5
Joined: Mon Sep 13, 2010 8:41 am

Re: Booting TonidoPlug using USB Drive

Postby synxer » Thu Sep 16, 2010 9:58 am

Is this a usable tutorial for TonidoPlug?

http://computingplugs.com/index.php/Boo ... USB_device

chrisblessing
Super Tonidoid
Super Tonidoid
Posts: 30
Joined: Fri Jun 11, 2010 3:41 pm
Location: Kuala Lumpur

Re: Booting TonidoPlug using USB Drive

Postby chrisblessing » Fri Sep 17, 2010 1:09 am

Like others I spent a lot of frustrated time and effort in getting the LAMP image to both boot and work properly off a USB hard drive. I did finally get it to work a short while ago. I won't bore you with the frustrating bits except to say that I made numerous attempts over a couple of months before it finally worked.

First, I installed the LAMP image to a USB flash drive. I did it entirely over ssh to the plug to get around the inconsistent permission and ownership issues. After determining that it would boot successfully I then attached both the HDD and flash drive to my computer. I created a boot partition on the HDD and did a dd of the single flash drive partition to the HDD boot partition.

It's important to note that if the external drive doesn't have external power, a pig-tail usb cable is necessary to assure sufficient power to the HDD, which may speed up the access speed sufficiently to boot from the drive.

So far this has worked consistently for the past month. All of the three partitions I created on this 250GB disk are available. I labeled and stashed the original USB flash drive in the event I ever have to repeat this process. Next step is to install phpmyadmin, and then image the entire drive so as to avoid having to go through this nonsense again. Currently, I'm accessing the default Tonido install via the TonidoID and using DynDns, with port-forwarding, to access the LAMP image.

Tuxedo
Tonido Team
Tonido Team
Posts: 1458
Joined: Wed Jan 28, 2009 11:30 pm

Re: Booting TonidoPlug using USB Drive

Postby Tuxedo » Fri Sep 17, 2010 8:48 am


synxer
Rookie Tonidoid
Rookie Tonidoid
Posts: 5
Joined: Mon Sep 13, 2010 8:41 am

Re: Booting TonidoPlug using USB Drive

Postby synxer » Sat Sep 18, 2010 11:18 pm

I am pleased to say that I finally got it working with a WD My Passport Essential.

Only thing is that I've been creating Tonidoid accounts repetitively through this process. I would like to reclaim a specific Tonidoid relay URL and retain my account as it was when I first set it up.

I've since lost my profiles, so I can't simply switch it over.

How can I recover this?

Thanks!
Nick

User avatar
madhan
Admin Tonidoid
Admin Tonidoid
Posts: 8617
Joined: Tue Dec 30, 2008 12:13 am
Location: Austin, TX, USA
Contact:

Re: Booting TonidoPlug using USB Drive

Postby madhan » Sun Sep 19, 2010 11:56 am

Unless you backup your profile data, it is not possible to recover your profile. We are adding support for this in the upcoming release to recover even if you didn't backup.

sudya
Rookie Tonidoid
Rookie Tonidoid
Posts: 9
Joined: Thu Sep 09, 2010 12:46 am

Re: Booting TonidoPlug using USB Drive

Postby sudya » Mon Sep 27, 2010 5:02 pm

I just got a Western Digital My Book Elite 2 TB USB 2.0 Desktop External Hard Drive and am facing the same problem - created an ext3 partition and the plug would not boot off of it. Anybody have luck with Western Digital and any tips of how to make it work properly?

Thanks

UPDATE: I managed to boot it up once, but looks like the usb drive is too slow to bootup and the plug opts-out to use internal flash. Is ther a way to tell the plug to "wait" a little bit longer?


Return to “TonidoPlug Support”

Who is online

Users browsing this forum: No registered users and 13 guests