Page 1 of 1

Unable to access TonidoPlug 1 after manual static ip

Posted: Mon Aug 27, 2018 6:17 am
by mattman

My Tonido has been working for for many years now, and no issues at all.

Just got a new router the other day, and noticed IP address for my plug had changed, and I really would prefer a static IP, sooo... I thought best means was to update network interface on the plug itself for Jaunty as specified : ... buntu-804/

I performed the following changes to /etc/networking/interfaces
I changed the following lines :

auto eth0
iface eth0 inet dhcp

#auto eth0
#iface eth0 inet dhcp

iface eth0 inet static

And then attempted to restart network :
sudo /etc/init.d/networking restart

At which point access via that ssh session died (as I expected). However the static ip specified is not pingable nor is the previous DHCP address (which was

- I tried unplugging network cable and replugging, waiting still not accessable.
- Tried rebooting completely, still no joy. The network lights keep flashing in a consist repeatable sequence which I think indicates it a consistent periodic handshake type request, possible initiated by router or by plug.
- I tried the reboot to flash (and not actually perform the flash) via following instructions, still not accessible : ... g_Flashing
Perhaps its not actually booting from the USB drive, sadly no way that I know of telling for sure. The USB drive I prepared
on my linux mint laptop via instructions at: ... sh_LinuxOS

Personally I think my changes must have corrupted the network interfaces file and therefore network connectivity cannot be established. So.. I am wondering how best to proceed from here. Is there any other means of physically getting access to the flash archive on the tonidoplug, changing this file back to what it was and rebooting. As the plug I believe is working fine, and ideally I'd prefer not to have to reflash back to Factory defaults.

Checking router list of connected devices sadly never shows an IP matching the Wired cable tonido is connected to. Although I did read on a post that static addresses don't always appear in this list which I am surprised by.

When booting, tonido two lights come on, one red and one green. Green light turns white for a bit then back to green. Red light remains on all the time. I can't remember if this is normal or not, as I very rarely actually look my plug it's hidden away and has up to now never need to be accessed.

Any advice much appreciated. Really hope it's not "bricked" !

- Matt

Re: Unable to access TonidoPlug 1 after manual static ip

Posted: Mon Aug 27, 2018 6:41 am
by mattman
I've tried rebooting from USB as specified : ... es:usbboot

As I don't have access to my plug steps 1, 9 and 10 could not be performed.

Sadly I cannot get my plug to boot from this flash drive.

Re: Unable to access TonidoPlug 1 after manual static ip

Posted: Mon Aug 27, 2018 7:41 am
by mattman
After much trial and error, rebooting the plug via reset pin hole on side of plug I've now managed to reboot the plug from the USB device. And it's booted into the images specified at ... es:usbboot and viewtopic.php?f=32&t=8365

However as I could not copy root credential information, I am unable to ssh onto the plug. I do now have a DHCP assigned IP address, gleaned from my router's connected device list, and clearly shows TonidoPlug.

So I really pleased with this progress. Just need to know what credentials I can now use for SSH access. What is the default root credentials for this these images ? And once I do manage to SSH in I presume (hope) it's just a matter of mounting the Flash drive and amending the network file and hope all is good then :)

Re: Unable to access TonidoPlug 1 after manual static ip

Posted: Mon Aug 27, 2018 8:33 am
by mattman
Getting further with each comment :)

I've found the default credentials :
User : root
Password: nosoup4u

As per Step 4 at : ... connection

Now to determine how to mount the flash drive and hopefully revert my previous error.

Re: Unable to access TonidoPlug 1 after manual static ip

Posted: Mon Aug 27, 2018 9:09 am
by mattman
And now to finally resolve my own question !

Once USB device is booted to determine what MTD devices are available :
# cat /proc/mtd
dev: size erasesize name
mtd0: 00100000 00020000 "u-boot"
mtd1: 00400000 00020000 "uImage"
mtd2: 1fb00000 00020000 "root"

Now attach the root mtd2 device:
# ubiattach /dev/ubi_ctrl -m 2
UBI device number 0, total 4056 LEBs (523321344 bytes, 499.1 MiB), available 0 LEBs (0 bytes), LEB size 129024 bytes (126.0 KiB)
root@TonidoPlug:~# ubinfo
UBI version: 1
Count of UBI devices: 1
UBI control device major/minor: 10:63
Present UBI devices: ubi0

Next mount the device :
# mkdir -p /mnt/flash
# mount -t ubifs ubi0:rootfs /mnt/flash

Make necessary edits interfaces file :
# vi /mnt/flash/etc/network/interfaces

Unmount and detach flash drive
# umount /mnt/flash
# ubidetach /dev/ubi_ctrl -m 2

Once this was done, I simply removed my USB drive and power cycled (via reset button-pin on side), and Plug has booted back up with DHCP assigned IP !! and I can ssh back in with my previous root credentials.

Phew - Not bricked, at least not yet until I do something equally as stupid again.