Page 1 of 1

Linux instructions

Posted: Sat Apr 24, 2010 11:27 am
by tedstur
On a 100% fresh install of Ubuntu 8.04

I could not get the setup_ubuntu804.sh script to run unless I first changed to the /tonidosdk/thirdparty subdirectory and then ran the script: ./setup_ubuntu804.sh

There is also a problem with the backward slashes in the command to run the setup script. They should be forward slashes, though in the end it didn't matter as the sh script had to be run from within the same subdirectory.

FYI only - no need to respond.

Re: Linux instructions

Posted: Sat Apr 24, 2010 1:24 pm
by Tuxedo
Thanks for reporting. We will fix the script.

Re: Linux instructions

Posted: Sun Apr 25, 2010 8:02 pm
by tedstur
Please forgive my Linux ignorance... but,

I am issuing the following commands after building from the source:

(switch to the ~/tonidosdk/build/bin/gcc/debug$ directory)

LD_LIBRARY_PATH=./
./tonidoconsole&

I get the following error:

./tonidoconsole: error while loading shared libraries: libbootstrap.so: cannot open shared object file: No such file or directory
[1] 22037
[1]+ Exit 127 ./tonidoconsole

However, when I do a "ls" of the folder, the libbootstrap.so library is definitely there.

Any ideas?

This is a clean install of Ubuntu 8.04 on a virtual machine.

Re: Linux instructions

Posted: Sun Apr 25, 2010 8:51 pm
by mikestaszel
As far as I know, Ubuntu 8.04 uses /etc/ld.so.conf.d files for it's ldconfig - I've experienced this error myself. What you can do is see if "/usr/local/tonido" is in the file /etc/ld.so.conf. After adding it, run "sudo ldconfig" and try again.

It's just the way that the libraries are placed that confuses Ubuntu and Linux in general. I've found that setting the LD path in Tonido's scripts doesn't help much, like you mentioned above.

If you need help, post your "/etc/ld.so.conf" here and I'll see what we can do.

Re: Linux instructions

Posted: Mon Apr 26, 2010 6:28 pm
by tedstur
Hmmm..... messed around with this and at this point it is winning, not me.

Ok, I went back to the original /etc/ld.so.conf and it looks like this:

include /etc/ld.so.conf.d/*.conf

Nothing else, just that. What should I add?

Thanks!!

Re: Linux instructions

Posted: Mon Apr 26, 2010 7:58 pm
by madhan
I see the problem. Please do an

export LD_LIBRARY_PATH=.


You are missing an 'export'. Incorrect instructions in the wiki. It has been fixed.

Re: Linux instructions

Posted: Mon Apr 26, 2010 8:52 pm
by tedstur
Yep, that did it.

Thanks!

Now... to figure out why and how that works...