OS X

Questions related to developing on the Tonido Platform
tedstur
Regular Tonidoid
Regular Tonidoid
Posts: 11
Joined: Thu Apr 15, 2010 7:50 am

OS X

Postby tedstur » Wed Apr 21, 2010 10:27 pm

I am trying to install and build the SDK on OS X (10.6.2 to be exact).

I am getting the following error:

$ sudo ./setup_darwin.sh
Password:
Clearing stage/libs
Copying Poco Darwin libs
Copying Sqlite3 Darwin libs
Copying CryptoPP Darwin libs
Copying GD Darwin libs
Copying libOpenSSL libs
Copying Boost Darwin libs
cp: directory libs does not exist
Copying Common Stuff
------------------------------
Darwin x86_32 libs staged for build.

Is the "directory libs does not exist" fatal? I assume so... as I can't get it to build.

User avatar
madhan
Admin Tonidoid
Admin Tonidoid
Posts: 8617
Joined: Tue Dec 30, 2008 12:13 am
Location: Austin, TX, USA
Contact:

Re: OS X

Postby madhan » Thu Apr 22, 2010 9:08 am

It appears that there is a bug in the setup_darwin.sh file. I don't have access to a Mac Machine now to verify this, but you could modify this line for the Boost Darwin Libs.

echo "Copying Boost Darwin libs"
cp boost/1.40.0/lib/x86-darwin/* stage/libs/

tedstur
Regular Tonidoid
Regular Tonidoid
Posts: 11
Joined: Thu Apr 15, 2010 7:50 am

Re: OS X

Postby tedstur » Thu Apr 22, 2010 6:35 pm

There are no files in the boost/1.40.0/lib/x86-darwin/ folder to copy.

User avatar
madhan
Admin Tonidoid
Admin Tonidoid
Posts: 8617
Joined: Tue Dec 30, 2008 12:13 am
Location: Austin, TX, USA
Contact:

Re: OS X

Postby madhan » Fri Apr 23, 2010 9:13 pm

Oh, I see. Unfortunately it is going me to look into this since I am traveling and am out of the country.


Return to “Tonido Platform Development”

Who is online

Users browsing this forum: No registered users and 2 guests