Tonido problem... (on Ubuntu 8.04.2)

Support for Tonido on the Desktop including Windows/Mac/Linux
EricBJ
Veteran Tonidoid
Veteran Tonidoid
Posts: 65
Joined: Thu Mar 19, 2009 12:12 am

Re: Tonido problem...

Postby EricBJ » Thu Mar 19, 2009 1:24 pm

Sent message and Tonido said it was okay, but my little tray icon is gone again...

Just to make sure we are both looking in the right place for the problem, here is what I was doing or trying to do when I discovered the problem...

I was setting up Tonido on my wife's Windows system so we could try being a group. I hope that wasn't a really bad thing since this is an invitation only beta...

I first discovered something was wrong when I tried to send her an invitation to the group. I haven't setup remote access for her since she wouldn't ever be using it.

Here is the log file...


Thanks,
Eric
Attachments
tonido.log
(32.74 KiB) Downloaded 322 times

Tuxedo
Tonido Team
Tonido Team
Posts: 1458
Joined: Wed Jan 28, 2009 11:30 pm

Re: Tonido problem...

Postby Tuxedo » Thu Mar 19, 2009 1:49 pm

Eric,
What you are doing is perfectly normal for tonido.
You are using it in the right way it should be used. You should be able to create
groups within your family and stay connected.

The issue with your system is that when it tries to connect to another machine (like when you tried to send a message)
it generates a security token. For some reason the randomizer of the crypto library fails to generate the token.
We've created the binaries you downloaded on Ubuntu 8.04. However your version is Ubuntu 8.04.2.
So there might be newer libraries that makes the cryptos to fail.
We will try to create an environment identical to your system and recreate the problem.

Meanwhile, can you please give us the hardware spec for your ubuntu system.
BTW, if you have another windows system you could create an account on that and try to do what your intending to do.

Thanks

EricBJ
Veteran Tonidoid
Veteran Tonidoid
Posts: 65
Joined: Thu Mar 19, 2009 12:12 am

Re: Tonido problem...

Postby EricBJ » Thu Mar 19, 2009 2:16 pm

Sure, I'll try on another system...

Hardware specs...

Intel D865PERL motherboard
Intel P4 2.26 Ghz cpu
1.5 Gb RAM
PowerColor Radeon 9600 video card
Maxtor 20 Gb hard drive
LG DVD-RW burner x2

...enough detail? I could run "lshw" for you...

Thanks,
Eric

Tuxedo
Tonido Team
Tonido Team
Posts: 1458
Joined: Wed Jan 28, 2009 11:30 pm

Re: Tonido problem...

Postby Tuxedo » Thu Mar 19, 2009 3:37 pm

Eric,
The only way to debug this problem is to recreate your situation in development environment.
We are in the process of recreating your environment here in the lab.
We will let you know if more information is needed and how our testing goes.

Thanks

EricBJ
Veteran Tonidoid
Veteran Tonidoid
Posts: 65
Joined: Thu Mar 19, 2009 12:12 am

Re: Tonido problem...

Postby EricBJ » Thu Mar 19, 2009 4:03 pm

I installed Tonido on another Windows system and created a new profile. I created a group and invited my wife. She received the invitation and accepted.

I am able to send her a message, but I am only able to connect to her through the web browser with IP address and port number.

Is this part of the same issue?

Eric

EricBJ
Veteran Tonidoid
Veteran Tonidoid
Posts: 65
Joined: Thu Mar 19, 2009 12:12 am

Re: Tonido problem...

Postby EricBJ » Thu Mar 19, 2009 4:06 pm

I think I just found an answer to my last question. ...popup blocker...

Popups allowed from 127.0.0.1, now I can connect...

Thanks,
Eric

Tuxedo
Tonido Team
Tonido Team
Posts: 1458
Joined: Wed Jan 28, 2009 11:30 pm

Re: Tonido problem...

Postby Tuxedo » Thu Mar 19, 2009 4:25 pm

Eric,
Glad to hear that. Will get back to you once we debug the Ubuntu issue.

Thanks

Tuxedo
Tonido Team
Tonido Team
Posts: 1458
Joined: Wed Jan 28, 2009 11:30 pm

Re: Tonido problem...

Postby Tuxedo » Thu Mar 19, 2009 7:01 pm

Eric,
We were able to reproduce the problem in a fresh ubuntu 8.0.4.2 installation.
We are currently working on a fix.
Will keep you posted.

Thanks

Tuxedo
Tonido Team
Tonido Team
Posts: 1458
Joined: Wed Jan 28, 2009 11:30 pm

Re: Tonido problem...

Postby Tuxedo » Fri Mar 20, 2009 3:00 pm

Eric,
We have a fix for your environment. It will part of the future releases.
But to get you going, we have a patch for you.
Steps to apply the patch on your ubuntu system:
1) Stop tonido instance and exit out of it. Make sure all tonido process are killed. `ps aux | grep tonido` should return no tonido process entries.
2) Download the patch on to a temp directory from the URL http://www.tonido.com/patch/03202009/to ... tch.tar.gz
3) Untar the patch. `tar zxvf tonido_linux_804_2_patch.tar.gz`
4) Copy the following two files into tonido installation directory.
` cp patch/libbootstrap.so /usr/local/tonido/libbootstrap.so `
` cp patch/libcore.so /usr/local/tonido/libcore.so `
5) Start tonido from the desktop menubar.
6) Now you should be able to login and use tonido normally.

Please let us know if you had any problems.
Thanks for spending time with us in debugging this problem.

EricBJ
Veteran Tonidoid
Veteran Tonidoid
Posts: 65
Joined: Thu Mar 19, 2009 12:12 am

Re: Tonido problem...

Postby EricBJ » Fri Mar 20, 2009 3:22 pm

Well the last 10 minutes have been good, no crashing, no disappearing tray icons. I think you can call this one fixed.

Happy to help...

Eric

Note - I do have a suggestion. Should I put it in a new Topic?


Return to “Tonido Software”

Who is online

Users browsing this forum: No registered users and 17 guests