Tonido SSL on server with IIS which already has 443

Support for Tonido on the Desktop including Windows/Mac/Linux
jules13
Regular Tonidoid
Regular Tonidoid
Posts: 13
Joined: Tue Feb 09, 2016 5:33 pm

Tonido SSL on server with IIS which already has 443

Postby jules13 » Fri Feb 12, 2016 2:17 pm

Hi,

Premise:
I installed the free Tonido in Window 10 Pro x64, then I made it run as a service, after that I copied the Biz files since I found on this forum that they are free now.
I created a self-signed certificate, combined the 2 pem files into one as described on Tonido help pages.
I put the servercert.pem in Tonido install directory (in C:\Users\user1\AppData\Roaming\Tonido).
I disabled relay, enabled SSL, created a dns entry to point to the server.
I already have a website in IIS bound to port 443 because of SSL, it's my webmail.

The problem:
When I try to access my Tonido url with https, I get the error Page Not Found.
As far as I figured it, you cannot have multiple websites bound to 443 on a machine on same interface.
Tonido seems to load an Apache webserver into it's own process. Don't know how to access the settings of that apache webserver, to bind it to a different network interface? or how to proceed...

Can you please help me with advice how to configure to have both IIS website and Tonido with SSL?
Thank tou.

jules13
Regular Tonidoid
Regular Tonidoid
Posts: 13
Joined: Tue Feb 09, 2016 5:33 pm

Re: Tonido SSL on server with IIS which already has 443

Postby jules13 » Wed Mar 01, 2017 3:18 pm

Bumping my old post, I left the problem alone for these months, but would like to have a go at it again. Any help would be appreciated.


Return to “Tonido Software”

Who is online

Users browsing this forum: No registered users and 7 guests