Page 1 of 1

Tonido SSL on server with IIS which already has 443

Posted: Thu Feb 11, 2016 7:33 pm
by jules13
Hi,

Premise:
I installed the free Tonido for Windows, then I made it run as a service, after that I copied the Biz files since I found on this forum that they are free now.
I created a self-signed certificate, combined the 2 pem files into one as described on Tonido help pages.
I put the servercert.pem in Tonido install directory (in C:\Users\user1\AppData\Roaming\Tonido).
I disabled relay, enabled SSL, created a dns A entry to point to the server.
We already have a website in IIS bound to port 443 because of SSL, it is the webmail.

The problem:
When I try to access my Tonido url with https, O get the error Page Not Found.
As far as I figured it, you cannot have multiple websites bound to 443 on a machine on same interface.
Tonido seems to load an Apache webserver into it's own process. Don't know how to access the settings of that apache webserver, to bind it to a different network interface? or how to proceed...

Question:
Can you please help me with advice how to configure the machine? So that webmail in IIS works on https and Tonido as well.
Thank tou.

Re: Tonido SSL on server with IIS which already has 443

Posted: Wed Mar 01, 2017 3:19 pm
by jules13
Bumping my old post, I left the problem alone for these months, but would like to have a go at it again. Any help would be appreciated.

Re: Tonido SSL on server with IIS which already has 443

Posted: Sun Mar 12, 2017 10:57 am
by jules13
I downloaded latest release of Tonido and SSL is working out of the box, I didn't do anything special and it just worked.